Одновременный запуск нескольких консолей администрирования сервера 1С на одном компьютере

Администрирование - Системное

bat консоль администрирования сервера 1С

17
Если у вас зоопарк разных платформ 1С, то вам было бы полезно запустить одновременно несколько консолей администрирования сервера 1С.

Создаем bat-ники. Столько, сколько у вас разных платформ.

Пример 1:

@echo off

start /wait regsvr32 /s "C:\Program Files (x86)\1cv8\8.3.13.1513\bin\radmin.dll"

start "C:\Windows\System32\mmc.exe" "C:\Program Files (x86)\1cv8\common\1CV8 Servers.msc"

Пример 2:

@echo off

start /wait regsvr32 /s "C:\Program Files (x86)\1cv8\8.3.10.2580\bin\radmin.dll"

start "C:\Windows\System32\mmc.exe" "C:\Program Files (x86)\1cv8\common\1CV8 Servers.msc"

 

bat-ники запускаем правой кнопкой мыши от имени администратора.

Результат:

17

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Darklight 18 27.12.18 15:01 Сейчас в теме
Многократно сталкивался с тем, что перегистрация com-компоненты не помогала - уж не знаю но компонента не перегистрировалась (без ошибок). Перепробовал много разных вариантов регистрации - в итоге все они переставали работать (на новых местах применения). Поэтому сейчас перешёл на альтернативный режим - у меня батники такие:

regedit /s "E:\1C\Start\8.3.13.1513.reg"
mmc /s "C:\Program Files (x86)\1cv8\common\1CV8 Servers.msc"


где в 8.3.13.1513.reg текст:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{52A0B0A1-9EDA-4B07-9F90-BECF36637FD7}\InprocServer32]
@="C:\\Program Files (x86)\\1cv8\\8.3.13.1513\\bin\\radmin.dll"
"ThreadingModel"="Both"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{C08A0F38-EFA5-4F60-8D4B-5D7709056530}\InprocServer32]
@="C:\\Program Files (x86)\\1cv8\\8.3.13.1513\\bin\\radmin.dll"
"ThreadingModel"="Both"
Показать


Текст лучше выгрузить из реестра свой - для конкретной машины - и менять в нём версию в reg файлах для запуска разных батников!
Dementor; i_lo; Jokemas; memb3r; +4 Ответить
4. agatdev_ilganas 29.12.18 10:23 Сейчас в теме
(1)
Хороший способ, я бы охарактеризовал как более рабочий.
А у Автора как более универсальный.
5. Darklight 18 29.12.18 10:48 Сейчас в теме
(4)разницы в универсальности не вижу (оба не шибко универсальны). А в надёжности - разницу наблюдал многократно на собственном опыте!
Тут бы, хорошо заскриптоваться - чтобы не плодить кучу файлов - а запустить скрипт, ткнуть в нужную версию (и быстро добавлять/удалять их) и чтобы дальше уже reg файл сгенерировался на основе этой версии и общих настроек каталогов - и запустил приведённый мной код.
Сделать такой скрипт не очень большая проблема - но вот сделать в нём интерактивную графическую часть... вот это я не знаю как! А без неё - это опять куча отдельно преднастроенных файлов на каждую версию - уже не так интересно. Можно, конечно, в отелльной ИБ на 1С всё это замутить - но это уже как-то перебор...

В любом случае к концу следующего года (максимум к концу 2020-го), я думаю, все эти костыли с СOM-консолью станут уже не актуальны, после перехода компаний на 1С: Предприятие 8.3.14 и более поздние релизы платформы.
2. rpgshnik 950 28.12.18 05:21 Сейчас в теме
3. agatdev_ilganas 29.12.18 10:22 Сейчас в теме
(2) Тут у Вас другие темы, в ваших ссылках установка 2х серверов а у автора запуск двух консолей!
6. Darklight 18 09.01.19 09:24 Сейчас в теме
(3)

https://infostart.ru/public/818909/
в конце статьи речь идёт о mms-оснастки разных версий. Там рассмотрен вариант через reg файлы

https://infostart.ru/public/829994/
в середине статьи речь идёт о mms-оснастки разных версий. Там рассмотрен вариант автора данной статьи

https://infostart.ru/public/71077/
ближе к концу статьи речь идёт о mms-оснастки разных версий. Там рассмотрен вариант автора данной статьи

https://infostart.ru/public/125933/
вот тут про mms-оснастку разных версий действительно ничего нет

В общем - тема вскользь уже тут подымалась, но до сих пор детально не была рассмотрена - так (как я уже написал в (5)) то что работает в одном случае, может не работать в другом и пока никто не написал почему так происходит (к сожалению, даже в данной статье). Для меня - вариант через reg файлы пока наиболее стабилен. Но, с выходом платформы 1С:Предприятие 8.3.14, думаю, со временем, администрирование кластера через оснастку mms окончательно уйдёт в прошлое (впрочем, ранее так говорили после выхода консольных утилит командной строки ras/rac - но им так и не удалось потеснить COM-оснастку mms, даже не смотря на то, что для не windows платформ это пока единственный вариант управления кластером; немного слукавил - так как есть ещё java-интерфейс, но он тоже через ras-агента работает).

Не понимаю, почему компания 1С не сделала web-интерфейс, ну хотя бы web-сервис для управления кластером - это же самое очевидное и современное решение! Да и сама компания 1С сейчас активно прикручивает web-сервисы к платформе 1С8 и конфигурациям. А такую важную вещь (которая есть у многих других конкурентов) не сделала! Ну да ладно, не будем о грустном!
7. Xershi 462 09.01.19 10:07 Сейчас в теме
(6) https://infostart.ru/public/876329/
Вот запилил самое нужное, наслаждайтесь!
8. Darklight 18 09.01.19 13:33 Сейчас в теме
(7)Ну и причём тут монитор использования лицензий?
9. Xershi 462 09.01.19 16:37 Сейчас в теме
(8) при том что если захотеть его можно допилить, а пока функционал только для лицензий.
10. Darklight 18 09.01.19 17:41 Сейчас в теме
(9)Конечно - если захотеть - можно много чего допилить. Тут придётся допиливать около 95% оставшегося функционала. И около 25% этого функционала будет действительно из категории "самое нужное", а просмотр лицензий я бы к этой категории не стал бы относить (хотя анализ лицензий - это тоже вещь полезная, но скорее как хорошее дополнение к основному функционалу), полезность вашей обработки в том, что она (как бы в нагрузку) умеет ещё сеансы прерывать! Но интерфейс для этого не самый удачный, на мой взгляд! Только не подумайте, что я хочу похаить Вашу разработку - эта вещь тоже полезная! Но гораздо полезнее - когда весь функционал доступен в комплексе и лаконично представлен в интерфейсе пользовательской юзабилити.

А на 8.3.14 получить используемые по сессиям лицензии можно гораздо проще

адм = Новый АдминистрированиеСервера(Адрес, Порт);
Если Логин = неопределено Тогда //Доменная авторизация
	адм.ВыполнитьАутентификацию();
Иначе
	адм.ВыполнитьАутентификацию(Логин, Пароль);
КонецЕсли;
Кластеры = адм.ПолучитьКластеры();
Для каждого Кластер из Кластеры Цикл
	Если Логин = неопределено Тогда //Доменная авторизация
		Кластер.ВыполнитьАутентификацию();
	Иначе
		Кластер.ВыполнитьАутентификацию(Логин, Пароль);
	КонецЕсли;
	Сеансы = Кластер.ПолучитьСеансы();
	Для каждого Сеанс из Сеансы Цикл
		Для каждого Лицензия из Сенас.Лицензии Цикл
			//Тут что-то делаем с данными о лицензии
		КонецЦикла;
	КонецЦикла;
КонецЦикла;
Показать


Данные лицензий содержат:
АдресСервера ""
ИдентификаторПроцесса "26252"
ИмяФайла ""
КраткоеПредставление "Клиент, ORGL8 Сет 100"
МаксимальноеКоличествоПользователей 100
МаксимальноеКоличествоПользователейПрограммнойЛицензии 100
ПодробноеПредставление "Клиент, 26252, ORGL8 Сетевой 100"
ПолученаСервером Ложь
ПортСервера 0
ПрограммнаяЛицензия Ложь
СерияКлюча "ORGL8"
СетевойКлюч Истина


Конечно, для утилиты RING пока нет такого API - но для ней действительно нужен свой отдельный продвинутый GUI - и, в первую очередь, не столько на просмотр, сколько на управление (взаимодействие с сервером лицензирования 1С).
11. Xershi 462 09.01.19 17:46 Сейчас в теме
(10) я к тому что рисовать ГУИ и навешать пару кнопок уже плевое дело, когда есть каркас. 95% того что вы написали это копипаст кнопки и замена текста команды не более!
Оставьте свое сообщение